Latency in Tasks
Resolved·Degraded performance

We have not had a recurrence of this issue now in production. Resolving this incident.

Mon, Feb 23, 2026, 10:58 AM
(4 days ago)
·
Affected components
Finster Application
Updates

Resolved

We have not had a recurrence of this issue now in production. Resolving this incident.

Mon, Feb 23, 2026, 10:58 AM

Monitoring

We have deployed a fix and are continuing to monitor.

Sun, Feb 22, 2026, 09:46 PM(13 hours earlier)

Identified

We have identified the root cause and have a fix. We are currently testing it.

Sat, Feb 21, 2026, 11:43 PM(22 hours earlier)

Identified

We have currently identified issues with tasks leading to increased latency of task completion. We are actively working to resolve it.

Sat, Feb 21, 2026, 11:21 PM(21 minutes earlier)